Thread Rating:
  • 251 Votes - 2.73 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Too Much Space below Black Bar
01-13-2010, 09:31 AM (This post was last modified: 01-13-2010 09:33 AM by infopage.)
Post: #1
Exclamation Too Much Space below Black Bar
I cannot figure out how to get rid of the extra space below the black bar. At first, I thought I could change it in the Nat Geo template files,but no change. I also tried changing the templaet itself but consistenetly get the following error mssg within my WP Featirific Admin:
Quote: Warning: file_get_contents() [function.file-get-contents]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/infopage/public_html/marketsecrets/blog/wp-content/plugins/featurific-for-wordpress/featurific.php on line 2128

Warning: file_get_contents(http://www.abid.in/images/banner_2.jpg) [function.file-get-contents]: failed to open stream: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/infopage/public_html/marketsecrets/blog/wp-content/plugins/featurific-for-wordpress/featurific.php on line 2128

..please help Huh

Idea Add Magic Code to Your Site Make Money Instantly!
One Man Did & Made $7,000 Just 24 Hours with No Work: The Magic Code
Find all posts by this user
01-14-2010, 05:03 AM
Post: #2
RE: Too Much Space below Black Bar
Hi infopage!

Can you post a link to your site so I can see the black bar problem you're talking about?

Also, regarding changing the template.xml file, in order to see the changes you've made reflected in the slideshow, you need to regenerate the data.xml file. This is done automatically every x minutes (per your chosen configuration). However, you can force a data.xml regeneration by submitting the Featurific options form (even if you have made no changes). Did you try this?

Finally, the errors you're getting indicate that your server is having difficulties locating a remote server/file. In fact, when I try to access the included url (http://www.abid.in/images/banner_2.jpg), I see that the server cannot be found. You may wish to check that you have the right URL, or perhaps simply upload the file to your local wordpress installation and reference the image locally.

Hope this helps! Smile
-Rich
Find all posts by this user
01-14-2010, 07:56 AM
Post: #3
RE: Too Much Space below Black Bar
The link is: MarketSecrets.biz and I went ahead and put that image into my Wordpress

Idea Add Magic Code to Your Site Make Money Instantly!
One Man Did & Made $7,000 Just 24 Hours with No Work: The Magic Code
Find all posts by this user
01-14-2010, 09:26 AM
Post: #4
RE: Too Much Space below Black Bar
Hi again,

Ok, I can see you are familiar with how to edit the template.xml file. To remove the black box, edit the template and remove this text:

<!-- Black portion at bottom, behind control panel. Note that this black portion is listed *after* the main image. This will cause the main image to be cropped by the lighter grey portion. This is necessary since we're using the 'min' resize type on the main image. -->
<image filename="templates/common/black.gif" x="0" y="210" width="480" height="30" resizetype="exact"/>

Then, re-submit the Featurific options page to force a data.xml regeneration, and the box should be gone!

Hope this helps,
-Rich
Find all posts by this user
01-14-2010, 10:14 AM
Post: #5
RE: Too Much Space below Black Bar
(01-14-2010 09:26 AM)rinogo Wrote:  Hi again,

Ok, I can see you are familiar with how to edit the template.xml file. To remove the black box, edit the template and remove this text:

<!-- Black portion at bottom, behind control panel. Note that this black portion is listed *after* the main image. This will cause the main image to be cropped by the lighter grey portion. This is necessary since we're using the 'min' resize type on the main image. -->
<image filename="templates/common/black.gif" x="0" y="210" width="480" height="30" resizetype="exact"/>

Then, re-submit the Featurific options page to force a data.xml regeneration, and the box should be gone!

Hope this helps,
-Rich

Didn't work..I assume by "re-submit the Featurific options page" you meant to hit UPDATE OPTIONS.

Idea Add Magic Code to Your Site Make Money Instantly!
One Man Did & Made $7,000 Just 24 Hours with No Work: The Magic Code
Find all posts by this user
01-14-2010, 10:31 AM
Post: #6
RE: Too Much Space below Black Bar
Hi again infopage,

I can see by inspecting your template ( http://marketsecrets.biz/blog/wp-content...mplate.xml ) that you've successfully removed the code (good work!). The only catch is that there are two screens in the NatGeo template! Smile So, simply remove the same code from the other <screen>...</screen> section in the template.xml file, hit 'Update Options', and everything should work as expected.

Hope this does it for you,
-Rich
Find all posts by this user
01-14-2010, 10:50 AM
Post: #7
Exclamation RE: Too Much Space below Black Bar
(01-14-2010 10:31 AM)rinogo Wrote:  Hi again infopage,

I can see by inspecting your template ( http://marketsecrets.biz/blog/wp-content...mplate.xml ) that you've successfully removed the code (good work!). The only catch is that there are two screens in the NatGeo template! Smile So, simply remove the same code from the other <screen>...</screen> section in the template.xml file, hit 'Update Options', and everything should work as expected.

Hope this does it for you,
-Rich

Now it's really messed up..my 11 recent posts do not show and there's still a bunch of space Huh

Idea Add Magic Code to Your Site Make Money Instantly!
One Man Did & Made $7,000 Just 24 Hours with No Work: The Magic Code
Find all posts by this user
01-15-2010, 08:11 AM
Post: #8
RE: Too Much Space below Black Bar
Hi there!

I can see that the code (that I referred to in my last post) is still present in one of the <screen>...</screen> portions of the template.xml. This is the reason that the black area is still showing up.

Accessing the data.xml file generator (at http://marketsecrets.biz/blog/wp-content...ta_xml.php ) shows that the data.xml file that is being generated by Featurific for Wordpress is essentially empty:

<data>

<notes>...(removed for conciseness)...</notes>

<size width="460" height="340" />

<controlpanel>
<button type="play" />
<button type="pause" />
<button type="numbers" />

</controlpanel>

</data>

I'm not sure why this is. How many posts do you have Featurific set to display? Also, what post selection type are you using? If the plugin is set to display zero posts or the post selection process yields zero posts, then a blank slideshow results.

Hope this helps and talk to you soon,
-Rich
Find all posts by this user
01-15-2010, 09:58 AM (This post was last modified: 01-15-2010 10:40 AM by infopage.)
Post: #9
RE: Too Much Space below Black Bar
I deleted all Featurific files and re-installed the whole thing then removed the "black portion.." text from both screens in template.xml and still NOTHING. I only have the code on the main index/home page set to display 11 most recent posts.
UPDATE: I just changed Storage location to "File System" for both data.xml and cached images and things seem to work now at MSB Big Grin

Please tell me any important info I may need to know for using the "File System" location option because you guys have the following in there:
Quote:..but is more difficult to set up than 'Database' storage

Idea Add Magic Code to Your Site Make Money Instantly!
One Man Did & Made $7,000 Just 24 Hours with No Work: The Magic Code
Find all posts by this user
01-16-2010, 04:45 AM
Post: #10
RE: Too Much Space below Black Bar
Hi there, infopage!

I'm happy to hear that it's working for you! There's no need to worry about the 'difficult to set up' text - if you've got it running, you've already set it up! Smile (some systems are harder to get running on the 'file system' than yours was)

Enjoy Featurific, and have a great weekend!
-Rich
Find all posts by this user


Possibly Related Threads...
Thread: Author Replies: Views: Last Post
  template <br> without the black border? Guest 4 13,056 02-25-2011 05:43 AM
Last Post: rinogo

Forum Jump:


User(s) browsing this thread: 1 Guest(s)